System Requirements

To run Design Master Electrical RT 2.0, you need:

A computer capable of running Autodesk Revit 2018 or later.

Autodesk Revit 2018 or later, including:

Autodesk Revit 2022
Autodesk Revit 2021
Autodesk Revit 2020
Autodesk Revit 2019
Autodesk Revit 2018

The following versions of Revit are supported by an older release (Design Master Electrical RT 1.4):

Autodesk Revit 2017
Autodesk Revit 2016
Autodesk Revit MEP 2015
Autodesk Revit MEP 2014

Older versions of Revit are not supported.


Page url: http://www.designmaster.biz/docs/elecrt/2.0/index.html?system_requirements.htm
©2013-2021 Design Master Software, Inc